pdns-recursor 4.0.0alpha2 Service cant be stopped.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

pdns-recursor 4.0.0alpha2 Service cant be stopped.

Aladme
Hi all,

I've installed this 4.0.0-alpha2 Recursor versión and I'm having some errors stopping or restarting the service.

The fact is when I try to stop the service, the service keeps running. When I restart the service, it cannot be restarted because it cannot be stopped.
Restart Exception: Resolver binding to server socket on port 8053 for xx.xx.xx.xx: Address already in use

The only way to stop it is killing the process.

To add some information, I saw two files on root folder, maybe is wrong place for they
   0 srwxr-xr-x   1 root pdns    0 Apr 27 16:35 pdns_recursor.controlsocket
4.0K -rw-r--r--   1 root pdns    5 Apr 27 16:35 pdns_recursor.pid

The only way I found to solve this issue is disabling the "chroot=./" setting.

As always I wrote here, can be my own problem but, I report this just in case.

Thank a lot, Ale.
_______________________________________________
Pdns-users mailing list
[hidden email]
https://mailman.powerdns.com/mailman/listinfo/pdns-users
Reply | Threaded
Open this post in threaded view
|

Re: pdns-recursor 4.0.0alpha2 Service cant be stopped.

Pieter Lexis-2
Hi Alejandro,

On Wed, 27 Apr 2016 15:08:21 +0000
Alejandro Adroher Mellado <[hidden email]> wrote:

> I've installed this 4.0.0-alpha2 Recursor versión and I'm having some errors stopping or restarting the service.
>
> The fact is when I try to stop the service, the service keeps running. When I restart the service, it cannot be restarted because it cannot be stopped.
> Restart Exception: Resolver binding to server socket on port 8053 for xx.xx.xx.xx: Address already in use
>
> The only way to stop it is killing the process.
>
> To add some information, I saw two files on root folder, maybe is wrong place for they
>    0 srwxr-xr-x   1 root pdns    0 Apr 27 16:35 pdns_recursor.controlsocket
> 4.0K -rw-r--r--   1 root pdns    5 Apr 27 16:35 pdns_recursor.pid
>
> The only way I found to solve this issue is disabling the "chroot=./" setting.

I think this works better if you use a full path for the `chroot`-setting. Could
you try that?

Best regards,

Pieter

--
Pieter Lexis
PowerDNS.COM BV -- https://www.powerdns.com
_______________________________________________
Pdns-users mailing list
[hidden email]
https://mailman.powerdns.com/mailman/listinfo/pdns-users