reverse dns zone does not working.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

reverse dns zone does not working.

kamil kapturkiewicz
Hi,
I've tried to configure reverse zone, so created domain + reverse zone:

mysql> SELECT * FROM domains;
+----+-------------------------+--------+------------+--------+-----------------+---------+
| id | name                    | master | last_check | type   | notified_serial | account |
+----+-------------------------+--------+------------+--------+-----------------+---------+
|  1 | domain.com            | NULL   |       NULL | NATIVE |      2015112401 | NULL    |
|  2 | 33.22.11.in-addr.arpa | NULL   |       NULL | NATIVE |      2015112401 | NULL    |

then appropriate records:

| 26 |  2 | 33.22.11.in-addr.arpa                 | SOA   | ns-uk-2.domain.com hostmaster.domain.com 2015112401 10800 3600 604800 3600   | 3600 |    0 |  2015112401 |        0 | NULL      |    1 |
| 29 |  2 | 33.22.11.in-addr.arpa                 | NS    | ns-uk-1.domain.com                                                             | 3600 |    0 |        NULL |        0 | NULL      |    1 |
| 30 |  2 | 33.22.11.in-addr.arpa                 | NS    | ns-uk-2.domain.com                                                             | 3600 |    0 |        NULL |        0 | NULL      |    1 |
| 31 | 2 | 59.33.22.11.in-addr.arpa              | PTR   | mail2.domain.com                                                               | 3600 |    0 |        NULL |        0 | NULL      |    1 |
| 32 | 2 | 60.33.22.11.in-addr.arpa              | PTR   | mail.domain.com                                                                | 3600 |    0 |        NULL |        0 | NULL      |    1 |
| 49 |         1 | domain.com                            | NS    | ns-uk-1.domain.com                                                             | 3600 |    0 |        NULL |        0 | NULL      |    1 |
| 50 |         1 | domain.com                            | NS    | ns-uk-2.domain.com                                                             | 3600 |    0 |        NULL |        0 | NULL      |    1 |
| 53 | 1 | ns-uk-1.domain.com                    | A     | 11.22.33.60                                                                    | 3600 |    0 |        NULL |        0 | NULL      |    1 |
| 54 | 1 | ns-uk-2.domain.com                    | A     | 11.22.33.59                                                                    | 3600 |    0 |        NULL |        0 | NULL      |    1 |

| 72 | 1 | mail.domain.com                       | A     | 11.22.33.60                                                                    | 3600 |    0 |        NULL |        0 | NULL      |    1 |
| 73 | 1 | mail2.domain.com                      | A     | 11.22.33.59                                                                    | 3600 |    0 |        NULL

| 93 |         1 | domain.com                            | SOA   | ns-uk-2.domain.com hostmaster.domain.com 2015112401 10800 3600 604800 3600   | 3600 |    0 |  2015112401 |        0 | NULL      |    1 |

problem is, that powerdns asked about reverse dns claims that there is no domain configured for ip (host -t any 11.22.33.59 127.0.0.1):

Nov 23 23:10:56 gw01 pdns[11003]: 1 slave domain needs checking, 0 queued for AXFR
Nov 23 23:10:56 gw01 pdns[11003]: Received serial number updates for 1 zones, had 0 timeouts
Nov 23 23:10:56 gw01 pdns[11003]: Domain 'domain.com' is stale, master serial 2015112322, our serial 0
Nov 23 23:10:56 gw01 pdns[11003]: Initiating transfer of 'domain.com' from remote '11.22.33.59'
Nov 23 23:10:56 gw01 pdns[11003]: gmysql Connection successful. Connected to database 'pdns' on 'localhost'.
Nov 23 23:10:56 gw01 pdns[11003]: No serial for 'domain.com' found - zone is missing?
Nov 23 23:10:56 gw01 pdns[11003]: AXFR started for 'domain.com'
Nov 23 23:10:56 gw01 pdns[11003]: Transaction started for 'domain.com'
Nov 23 23:10:56 gw01 pdns[11003]: AXFR done for 'dp,aom.com', zone committed with serial number 2015112322

slave dns won't download updated records, because of wrong serial number (even if updated manually in db on master dns). currently slave keeps only few records, but not all of them.
I've added second domain using nsedit web interface this time, and it seems to be working fine. Previously I've created master domain and reverse zone and I've had the same situation (reverse zone has not worked).

For tests, I am running Bind and reverse zone is visible in internet in few minutes. What I am doing wrong?







_______________________________________________
Pdns-users mailing list
[hidden email]
http://mailman.powerdns.com/mailman/listinfo/pdns-users
Reply | Threaded
Open this post in threaded view
|

Re: reverse dns zone does not working.

Jan-Piet Mens-3

>  What I am doing wrong?

You are obfuscating data, and possibly copy/pasting it incorrectly:

> Nov 23 23:10:56 gw01 pdns[11003]: AXFR done for 'dp,aom.com', zone committed with serial number 2015112322

                                                   ^^^

There is no way people are going to help you this way.

        -JP

_______________________________________________
Pdns-users mailing list
[hidden email]
http://mailman.powerdns.com/mailman/listinfo/pdns-users